Prerequisite bolalob environment

Before you starting running the bolalob sites in your computer, you must check and install several application, to see that you have qualify hardware and software need for running the project on your operating system. The requirements for each type of operating system are detailed in the following sections:

Windows

  • Install Git Version 2.17.1 up
  • Install Java Development Kit (JDK) Version 7 up to 8
  • Install PostgreSQL Database
  • Install IDE Spring Tools Suite or others IDE
  • Setup Thymeleaf Framework (Front-end)
  • Setup Spring Framework (Backend)

Linux

  • Install Git Version 2.17.1 up
  • Install Java Development Kit (JDK) Version 7 up to 8
  • Install PostgreSQL Database
  • Install IDE Spring Tools Suite or others IDE
  • Setup Thymeleaf Framework (Front-end)
  • Setup Spring Framework (Backend)

MacOS

  • Install Git Version 2.17.1 up
  • Install Java Development Kit (JDK) Version 7 up to 8
  • Install PostgreSQL Database
  • Install IDE Spring Tools Suite or others IDE
  • Setup Thymeleaf Framework (Front-end)
  • Setup Spring Framework (Backend)

Note

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales mi et neque pharetra, sit amet volutpat odio aliquam. Suspendisse at sollicitudin erat.

Warning

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales mi et neque pharetra, sit amet volutpat odio aliquam. Suspendisse at sollicitudin erat.

Danger

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Aliquam sodales mi et neque pharetra, sit amet volutpat odio aliquam. Suspendisse at sollicitudin erat.